Примеры использования условий в формулах Excel

Здравствуйте, друзья! Часто ли вам приходится делать выбор? Например, захотели купить новый телефон, а полной суммы денег у вас нет. Взять кредит или копить? Так сегодня разберем как делать выбор в электронных таблицах Excel. Это позволяет сделать условная функция ЕСЛИ().

Условная функция ЕСЛИ()

В этой функции проверяется истинность  одного или нескольких логических выражений и выбирается дальнейшее действие. В логических выражениях используют знаки операций отношения между сравниваемыми величинами.

операции отношения в логических выражениях
Операции отношения в логических выражениях

Простое условие

Что же делает функция ЕСЛИ()? Посмотрите на схему. Здесь приведен простой пример работы функции при определении знака числа а.

операции отношения в логических выражениях
Блок-схема "Простое условие". Определение отрицательных и неотрицательных чисел

Условие а>=0 определяет два возможных варианта: неотрицательное число (ноль или положительное) и отрицательное. Ниже схемы приведена запись формулы в Excel. После условия через точку с запятой перечисляются варианты действий. В случае истинности условия, в ячейке отобразится текст "неотрицательное", иначе - "отрицательное". То есть запись, соответствующая ветви схемы «Да», а следом – «Нет».

Текстовые данные в формуле заключаются в кавычки, а формулы и числа записывают без них.

Если результатом должны быть данные, полученные в результате вычислений, то смотрим следующий пример. Выполним увеличение неотрицательного числа на 10, а отрицательное оставим без изменений.

формула если простое условие в эксель
Блок-схема "Простое условие". Расчет данных

На схеме видно, что при выполнении условия число увеличивается на десять, и в формуле Excel записывается расчетное выражение А1+10 (выделено зеленым цветом). В противном случае число не меняется, и здесь расчетное выражение состоит только из обозначения самого числа А1 (выделено красным цветом).

Это была краткая вводная часть для начинающих, которые только начали постигать азы Excel. А теперь давайте рассмотрим более серьезный пример с использованием условной функции.

Задание:
Процентная ставка прогрессивного налога зависит от дохода. Если доход предприятия больше определенной суммы, то ставка налога выше. Используя функцию ЕСЛИ, рассчитайте сумму налога.

Решение:

Решение данной задачи видно на рисунке ниже. Но внесем все-таки ясность в эту иллюстрацию. Основные исходные данные для решения этой задачи находятся в столбцах А и В. В ячейке А5 указано пограничное значение дохода при котором изменяется ставка налогообложения. Соответствующие ставки указаны в ячейках В5 и В6. Доход фирм указан в диапазоне ячеек В9:В14. Формула расчета налога записывается в ячейку С9: =ЕСЛИ(B9>A$5;B9*B$6;B9*B$5). Эту формулу нужно скопировать в нижние ячейки (выделено желтым цветом).

прогрессивный налог в эксель

В расчетной формуле адреса ячеек записаны в виде A$5, B$6, B$5. Знак доллара делает фиксированной часть адреса, перед которой он установлен, при копировании формулы. Здесь установлен запрет на изменение номера строки в адресе ячейки.

Составное условие

Составное условие состоит из простых, связанных логическими операциями И() и ИЛИ().

И() - логическая операция, требующая одновременного выполнения всех условий, связанных ею.
ИЛИ() - логическая операция, требующая выполнения любого из перечисленных условий, связанных ею.

Логическая операция И()

Например: Рассмотрим электронную таблицу "Ведомость сдачи вступительных экзаменов". Для зачисления абитуриента в ВУЗ, ему необходимо преодолеть проходной балл, и по математике отметка должна быть выше 70 баллов.
Посмотрите внимательно на рисунок ниже.

Составное условие в Excel

В этом примере функция ЕСЛИ() использует составное условие, связанное логической операцией И(). Обратите внимание: абитуриент Петров не зачислен, хотя сумма его баллов равна проходному.

Почему так произошло? Посмотрим внимательно на условие в нашей формуле =ЕСЛИ(И(E6>=D2;B6>70);"зачислен";"не зачислен"). Логическая операция И() требует выполнения всех условий, но у нас выполняется только одно. Второе условие B6>70 не выполнено, поэтому составное условие принимает значение «ложь». И на экран выводится сообщение «не зачислен» (вспоминаем схему – ветвь «нет»).

Задание:
В торговой фирме перед Новым Годом устроена праздничная распродажа. Рассчитать сумму продаж с учетом скидки, назначаемой в период распродажи.

1. Рассчитайте общую стоимость продаж. Итого = Стоимость* Количество.

2. Определите скидку (в процентах), используя функцию ЕСЛИ(). Если дата продажи попадает в период праздничной распродажи, то назначается скидка, иначе скидка равняется нулю. При задании условий используйте логическую функцию И().

3. Определите сумму продажи с учетом скидки. Сумма продажи с учетом скидки = Итого* (1- Скидка%).

Решение:

примел логической функции И()

Для проведения расчетов необходимо вписать следующие формулы:

  • В ячейке Е7: =B7*C7
  • В ячейке F7: =ЕСЛИ(И(D7>=D$4;D7<=E$4);B$4;0)
  • В ячейке G7: =E7*(1-F7)

и скопировать по соответствующим столбцам до 16 строки включительно.

Логическая операция ИЛИ()

Посмотрим пример с логической операцией ИЛИ() в той же таблице. Только немного изменим условие задачи. Для зачисления абитуриента достаточно иметь по математике более 60 баллов или общую сумму баллов не меньше проходного. Рисунок ниже.

Пример Если несколько условий в excel

Абитуриент Сидоров зачислен, хотя не набрал проходной балл. Вот формула =ЕСЛИ(ИЛИ(B7>60;E7>D2;);"зачислен";"не зачислен"). Здесь использована операция ИЛИ(), поэтому достаточно выполнение хотя бы одного условия. Что и произошло, первое условие B7>60 истинно. Оно привело к выводу сообщения о зачислении абитуриента.

Задание:
В торговой фирме установлены дни распродаж - последние числа месяца. Рассчитать сумму продаж с учетом скидки, назначаемой в дни распродажи.

1. Рассчитайте общую стоимость продаж. Итого = Стоимость* Количество.

2. Определите скидку (в процентах), используя функцию ЕСЛИ(). Если дата продажи совпадает с датами распродаж, то назначается скидка, иначе скидка равняется нулю. При задании условий используйте логическую функцию ИЛИ().

3. Определите сумму продажи с учетом скидки. Сумма продажи с учетом скидки = Итого* (1- Скидка%)

Решение:

пример логической функции ИЛИ()

Для проведения расчетов необходимо вписать следующие формулы:

  • В ячейке Е7: =B7*C7
  • В ячейке F7: =ЕСЛИ(ИЛИ(D7=D$4;D7=E$4;D7=F$4);B$4;0)
  • В ячейке G7: =E7*(1-F7)

и скопировать по соответствующим столбцам до 15 строки включительно.

Вложенные условия

Если для решения задачи недостаточно использования составных условий, то тогда применяют более сложную конструкцию вложенных условий. Смотрите схему.

вложенные условия формула если

В данном примере вторая функция ЕСЛИ() является вложенной и записывается на месте действия, которое вызывается при не выполнении условия первой функции. В Excel последних версий допускается делать до 64 вложений.

Задание:
С целью уменьшения текучести кадров администрация решила выплачивать надбавку за непрерывный стаж работы на своем предприятии. Рассчитайте надбавку за непрерывный стаж работы в соответствии с таблицей Надбавка.

1. Определите стаж работы сотрудников. Стаж = 2018- Год приема на работу.

2.  Используя вложенные функции Если, рассчитайте надбавку для сотрудников. Надбавка (руб.) = Надбавка(%)* Оклад

Решение:

пример вложенной функции ЕСЛИ()

Для проведения расчетов необходимо вписать следующие формулы:

  • В ячейке D9: =2018-B9
  • В ячейке E9: =ЕСЛИ(D9>=B$6;C9*C$6;ЕСЛИ(D9>=B$5;C9*C$5;0))

и скопировать по соответствующим столбцам до 19 строки включительно.

В этой статье я постарался максимально подробно и доходчиво объяснить применение условной функции в Excel. Конечно же, в Excel есть и другие функции с условием, но о них поговорим в следующей статье. Друзья, если вам была интересна и полезна данная информация, не забывайте делиться ею в социальных сетях. А также буду рад прочитать ваши комментарии.

Дополнительная информация:

Дорогой читатель! Вы посмотрели статью до конца.
Получили вы ответ на свой вопрос? Напишите в комментариях пару слов.
Если ответа не нашли, укажите что искали.

Рекомендовано Вам:
Понравилась статья? Поделиться с друзьями:
Комментариев: 1
  1. Цифровой

    Блин, эти формулы в экселе это что-то с чем-то ))) Проще, наверное, язык программирования освоить )

Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!:
Нажимая на кнопку "Отправить комментарий", я даю согласие на рассылку, обработку персональных данных и принимаю политику конфиденциальности.